当前位置:首页 >  问答

通达信主散博弈选股公式

我来帮TA回答

请老师将下面的通达信公式改为选股公式,要求选出当天(主买卖差:=主买-主卖)+(散买卖差:=散买-散...

成交额:=AMOUNT;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=AMOUNT/IF(HIGH=LOW,4,HIGH-LOW);
主买:=ABS(QJ0*(JJ-MIN(CLOSE,OPEN)));
主卖:=(QJ0*(MIN(OPEN,CLOSE)-LOW));
散买:=(QJ0*(HIGH-MAX(OPEN,CLOSE)));
散卖:=ABS(QJ0*(MAX(CLOSE,OPEN)-JJ));
主买卖差:=主买-主卖;
散买卖差:=散买-散卖;
选股:主买卖差+散买卖差>0;

请求高手把资金博弈指标做成通达信选股预警指标。主力线上穿金叉散户线

效果图:,不过该公式有未来函数,请小心使用。 DI:=EMA(CLOSE,12)-EMA(CLOSE,26);DC:=EMA(DI,240);D1:=EMA(DI,5);E1:=DI-DC;F1:=ABS(E1);D2:=EMA(DI,10);E2:=D1-DC;F2:=ABS(E2);D3:=EMA(DI,20);E3:=D2-DC;F3:=ABS(E3);D4:=EMA(DI,30);E4:=D3-DC;F4:=ABS(E4);D5:=EMA(DI,45);E5:=D4-DC;F5:=ABS(E5);D6:=EMA(DI,60);E6:=D5-DC;F6:=ABS(E6);D7:=EMA(DI,90);E7:=D6-DC;F7:=ABS(E7);D8:=EMA(DI,100);E8:=D7-DC;F8:=ABS(E8);D9:=EMA(DI,120);E9:=D8-DC;F9:=ABS(E9);D0:=EMA(DI,150);E0:=D9-DC;F0:=ABS(E0);DA:=EMA(DI,180);EA:=D0-DC;FA:=ABS(EA);DB:=EMA(DI,200);EB:=DA-DC;FB:=ABS(EB);EC:=DB-DC;FC:=ABS(EC);FX:E1+E2+E3+E4+E5+E6+E7+E8+E9+E0+EA+EB+EC,COLORRED,LINETHICK2;JS:F1+F2+F3+F4+F5+F6+F7+F8+F9+F0+FA+FB+FC,STICK,COLORMAGENTA,LINETHICK2;IF(BACKSET(JS<REF(JS,1),1),JS,DRAWNULL),STICK,COLORGREEN,LINETHICK2;IF(BACKSET(FX>=REF(FX,1),1),FX,DRAWNULL),COLORYELLOW,LINETHICK2;0,COLORGRAY;1.5,COLORGRAY,LINETHICK2;AA:=1110730;SFX:=EMA(2500*(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20)),7)/200;ZJX:=EMA(2500*(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)),2)/200;散户线:IF(DATE<=AA,SFX,0),COLORGREEN,LINETHICK2;庄家线:IF(DATE<=AA,ZJX,0),COLORFF00FF,LINETHICK2;DRAWTEXT(庄家线<500,3,'底'),COLORGREEN,LINETHICK2;DRAWTEXT(散户线<500,2,'大底'),COLORRED,LINETHICK2;

请高手把通达信里的布局主升浪指标改成选股公式

P13:=MA(C,13);
VAR1:=HHV(H,9)-LLV(L,9);
VAR2:=HHV(H,9)-C;
截图没有意义,要文字说明。没有指定选股条件,无法编写。

通达信主图公式改成三个选股公式?

可以编写三个选股公式

第一个上面第一天出黄柱

第二个下面第一天出黄柱

第三个下面已黄柱上面第一天出黄柱

效果如图

资金博弈指标 通达信公式源代吗

{资金博弈}
V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
HY1:=REF(EMA(V1,3),1);
多空趋势:=(MA((CLOSE - HY1) * 28,2))*0.1;
操盘4:STICKLINE(多空趋势>=0 AND 多空趋势>=REF(多空趋势,1),24,24+多空趋势,1.5,0),COLORRED;
减仓4:STICKLINE(多空趋势>=0 AND 多空趋势< REF(多空趋势,1),24,24+多空趋势,1.5,0), COLORRED;
反弹4:STICKLINE(多空趋势<0 AND 多空趋势>=REF(多空趋势,1),24,22+多空趋势,1.5,0),COLORGREEN;
寻底4:STICKLINE(多空趋势<0 AND 多空趋势< REF(多空趋势,1),24,24+多空趋势,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(多空趋势>=0,22,22.3),' 多空'),COLORWHITE;
换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
成交量:V,COLORWHITE,NODRAW;
主力能量:(主力-均量)COLORMAGENTA,NODRAW;
大户能量:(大户-均量)COLORYELLOW,NODRAW;
中户能量:(中户-均量)COLORLIBLUE,NODRAW;
散户能量:(散户-均量)COLORBLUE,NODRAW;
操盘:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORRED;
减仓:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORYELLOW;
反弹:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORGREEN;
寻底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,14.4,14.6),' 机构'),COLORMAGENTA;
操盘1:STICKLINE(大户能量>=0 AND 大户能量>=REF(大户能量,1),9.6,9.6+大户能量,1.5,0),COLORRED;
减仓1:STICKLINE(大户能量>=0 AND 大户能量< REF(大户能量,1),9.6,9.6+大户能量,1.5,0),COLORYELLOW;
反弹1:STICKLINE(大户能量<0 AND 大户能量>=REF(大户能量,1),9.6,9.6+大户能量,1.5,0),COLORGREEN;
寻底1:STICKLINE(大户能量<0 AND 大户能量< REF(大户能量,1),9.6,9.6+大户能量,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(大户能量>=0,9.6,9.8),' 大户'),COLORYELLOW;
操盘2:STICKLINE(中户能量>=0 AND 中户能量>=REF(中户能量,1),4.8,4.8+中户能量,1.5,0),COLORRED;
减仓2:STICKLINE(中户能量>=0 AND 中户能量< REF(中户能量,1),4.8,4.8+中户能量,1.5,0),COLORRED;
反弹2:STICKLINE(中户能量<0 AND 中户能量>=REF(中户能量,1),4.8,4.8+中户能量,1.5,0),COLORGREEN;
寻底2:STICKLINE(中户能量<0 AND 中户能量< REF(中户能量,1),4.8,4.8+中户能量,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(中户能量>=0,4.8,5),' 中户'),COLORLIBLUE;
操盘3:STICKLINE(散户能量>=0 AND 散户能量>=REF(散户能量,1),0,散户能量,1.5,0),COLORRED;
减仓3:STICKLINE(散户能量>=0 AND 散户能量< REF(散户能量,1),0,散户能量,1.5,0),COLORRED;
反弹3:STICKLINE(散户能量<0 AND 散户能量>=REF(散户能量,1),0,散户能量,1.5,0),COLORGREEN;
寻底3:STICKLINE(散户能量<0 AND 散户能量< REF(散户能量,1),0,散户能量,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(散户能量>=0,-0.3,0.3),' 散户'),COLORBLUE;
JZ:=V/(ABS(主力能量)+ABS(大户能量)+ABS(中户能量)+ABS(散户能量));{4,9,17,34日换手偏离值均分成交量}
ZLCJ:=JZ*ABS(主力能量);{4日换手偏离均量值换算当日成交量}
DHCJ:=JZ*ABS(大户能量);{9日换手偏离均量值换算当日成交量}
ZHCJ:=JZ*ABS(中户能量);{17日换手偏离均量值换算当日成交量}
SHCJ:=JZ*ABS(散户能量);{34日换手偏离均量值换算当日成交量};
换手率:VOL/CAPITAL*100,LINETHICK0;
机构量:=ZLCJ,COLORMAGENTA,NODRAW;
大户量:=DHCJ,COLORYELLOW,NODRAW;
中户量:=ZHCJ,COLORLIBLUE,NODRAW;
散户量:=SHCJ,COLORBLUE,NODRAW;
股票公式专家团为你解答,希望能帮到你,祝投资顺利。

通达信资金博弈超大上穿散户选股公式

你的这个公式的"散户"定义是什么?请说明。