当前位置:首页 >  问答

通达信趋势龙指标公式源代码

我来帮TA回答

谁有通达信的济安线指标公式源代码

[通达信] 通达信济安线主图源码公式:
通达信济安线主图源码公式
AA:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,N))/MA(CLOSE,N);
济安线:DMA((2*CLOSE+LOW+HIGH)/4,AA),LINETHICK3,COLORMAGENTA;
CC:=(CLOSE/济安线);
MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);
MAAA:=((MA1-济安线)/济安线)/3;
TMP:=MA1-MAAA*MA1;
J:IF(TMP<=济安线,济安线,DRAWNULL),LINETHICK3,COLORCYAN;
A:TMP,LINETHICK2,COLORYELLOW;
X:IF(TMP<=济安线,TMP,DRAWNULL),LINETHICK2,COLORGREEN

程序化交易模型 指标通达信指标公式源码

分久必和.和久必分.重叠在一起寻求突破.

强势龙头个股通达信指标公式源码

主动撤单证券公司收取一元手续费

主力资金监测通达信指标公式源码

源码导入进去是错误的

我这边有一个通达信买卖力道指标,请高手帮我写一个买卖力道下穿买进区的选股公式。

这个太专业了,得花钱找编程专家合作才好用

通达信买入指标 改成 卖出指标 3个指标改成卖的

VAR1:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,1)*100,COLORGREEN,LINETHICK2;
VAR2:=IF((VAR1 > 0),VAR1,0),CIRCLEDOT;
VAR4:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
VAR5:=(EMA(VAR4,3)-50)*2; VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13),COLORGREEN,LINETHICK2;
VAR10:=EMA(0.382*REF(VAR9,2)+0.618*VAR9,6),COLORRED;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX); DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:=CROSS(最佳买入,0);
出局:REF(最佳买入,1)>=200 AND 最佳买入<REF(最佳买入,1);

{公式2}
VARH2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VARH3:=SMA(SMA(VARH2,3,1),3,1)/28.57;
VARH4:=EMA(VARH3,5);
操盘:=3*VARH3-2*VARH4;
大趋势买入:=CROSS(操盘,VARH3) AND VARH3<2.1 AND C>O;
卖出:REF(操盘,1)>=3 AND 操盘<REF(操盘,1);


{公式3}
A4:=MA(CLOSE,20);
A5:=(CLOSE > MA(CLOSE,5));   
A6:=(MA(CLOSE,5) >MA(CLOSE,10));  
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));  
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);   
A11:=(A4 >A10);
AVX:=(((((IF(A5,10,(0-10))+IF(A6,10,(0-10)))+IF(A7,10,(0 - 10)))+IF(A8,10,(0-10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 -10)));
AVX零轴:=0;
AA:=CROSS(AVX,AVX零轴);
卖:REF(AVX,1)>=0 AND AVX<0;

{很高兴回答您的问题,按您的要求,已经给您的3个公式分别都加上了出局信号,隐藏了建仓信号。希望能够帮到您,也祝您投资顺利!}